Page 12 of 13 FirstFirst ... 210111213 LastLast
Results 111 to 120 of 129

Thread: Taking a chance on a Stoeger M3000 Freedom Series Defense Shotgun - opinions?

  1. #111
    Site Supporter Lon's Avatar
    Join Date
    Apr 2011
    Location
    Dayton, Ohio
    Figured out the problem w my shotgun. I tightened the Magpul sling swivel down tight enough to pinch the follower/spring. Once I took the sling adapter off it worked great. So back to the drawing board for a sling option.
    Formerly known as xpd54.
    The opinions expressed in this post are my own and do not reflect the opinions or policies of my employer.
    www.gunsnobbery.wordpress.com

  2. #112
    Site Supporter Lon's Avatar
    Join Date
    Apr 2011
    Location
    Dayton, Ohio
    Just another data point. Weird as hell. With the lightened recoil spring from MOA precision, this thing will run the hell out of 3 1/4 Dram 7.5 field loads, LE127RS slugs, Federal Deep Penetrator slugs and some cheap ass Privi Star and Stripes 9 pellet buck. But it wonít run the 8 or 9 pellet FC loads worth a shit. Put the factory spring back in and it wonít run anything well. Weird. I ordered a couple other factory recoil springs. May put one of them in and try it again.
    Formerly known as xpd54.
    The opinions expressed in this post are my own and do not reflect the opinions or policies of my employer.
    www.gunsnobbery.wordpress.com

  3. #113
    Site Supporter
    Join Date
    Jul 2017
    Location
    Texas
    Quote Originally Posted by Lon View Post
    Just another data point. Weird as hell. With the lightened recoil spring from MOA precision, this thing will run the hell out of 3 1/4 Dram 7.5 field loads, LE127RS slugs, Federal Deep Penetrator slugs and some cheap ass Privi Star and Stripes 9 pellet buck. But it wonít run the 8 or 9 pellet FC loads worth a shit. Put the factory spring back in and it wonít run anything well. Weird. I ordered a couple other factory recoil springs. May put one of them in and try it again.
    I bought a 3000 and followed factory break in suggestions. My young friend ran 100 rounds of heavy loads through the gun. We cleaned it and proceeded to shoot "everything" through it. The 3000 feeds low recoil Federal buckshot without a hitch. In this gun I removed the extractor before firing it and found burrs where the extractor fits. I removed burrs. Also I cleaned the bolt and put heavy grease on the spring therein that drives this mechanism.

    Unlike some vendors Stoeger has helpful customer service folks. I would call them if my gun had issues. My guess is that the shotgun above has a problem within the trigger group that impedes the lifter. If not that, the problem may be the feed mechanism allowing shells to enter onto the lifter. Most likely burrs are the culprit.

  4. #114
    Quote Originally Posted by Lon View Post
    Just another data point. Weird as hell. With the lightened recoil spring from MOA precision, this thing will run the hell out of 3 1/4 Dram 7.5 field loads, LE127RS slugs, Federal Deep Penetrator slugs and some cheap ass Privi Star and Stripes 9 pellet buck. But it wonít run the 8 or 9 pellet FC loads worth a shit. Put the factory spring back in and it wonít run anything well. Weird. I ordered a couple other factory recoil springs. May put one of them in and try it again.
    Strange. So far, mine is running fine with everything I put through it. I am running the MOA light spring.

  5. #115
    Quote Originally Posted by 4given View Post
    Strange. So far, mine is running fine with everything I put through it. I am running the MOA light spring.
    Once I put the MOA Light Spring in I had no problems either. Although, I haven't shot anything less than 1200 FPS so far which, previously, I had a problem with 1200 FPS.

  6. #116
    Site Supporter Lon's Avatar
    Join Date
    Apr 2011
    Location
    Dayton, Ohio
    Quote Originally Posted by SiperTed View Post
    Once I put the MOA Light Spring in I had no problems either. Although, I haven't shot anything less than 1200 FPS so far which, previously, I had a problem with 1200 FPS.
    Thatís the kinda stuff Iím having issues with. The FC LE132 and LE133 is running under 1200fps. Iím gonna try to scrounge up some LE127 and see if that runs better. Itís running @1325
    Formerly known as xpd54.
    The opinions expressed in this post are my own and do not reflect the opinions or policies of my employer.
    www.gunsnobbery.wordpress.com

  7. #117
    Quote Originally Posted by Lon View Post
    Thatís the kinda stuff Iím having issues with. The FC LE132 and LE133 is running under 1200fps. Iím gonna try to scrounge up some LE127 and see if that runs better. Itís running @1325
    I have a bunch of the LE127 and it worked fine with the stock spring and the MOA light spring.

    My son and I are going to the range tomorrow and testing a bunch of different light rounds. The reason I bought the light spring was because, like you, I was having issues with 1200FPS and lighter loads. I had tested a bunch of light loads previously but lost the sheet that I wrote everything down on so now I'm out to try it again because I can't remember it all by memory. I'm almost positive that with the stock spring all of the 1200FPS or less loads I was having issues with. After I installed the MOA light spring all of them worked.

    Here is what I'll be testing tomorrow:

    Winchester Game & Target 020892020122 2.75" #8 1200
    Noble 9 Pellet 837913000861 2.75" #00 1200
    Federal 8 Pellet (LE133 00) 029465023157 2.75" #00 1145
    S&B 754908533183 2.75" #00 1200
    Fiochi 762344850078 3.00" #4 1200

    Here is what I know works with stock and with MOA light spring:

    Rio 9 Pellet 8435101618700 2.75" #00 1345
    Hornady Critical Defense 090255862409 2.75" #00 1600
    Mili 9 Pellet 860005040001 2.75" #00 1350
    Federal 9 Pellet (LE127 00) 029465025076 2.75" #00 1325
    Federal Slug 029465009946 2.75" Slug 1520
    Winchester Super X 020892015456 3.00" #4 1400

    I'll report back tomorrow and let you know How the lighter loads worked.

  8. #118
    Site Supporter Lon's Avatar
    Join Date
    Apr 2011
    Location
    Dayton, Ohio
    Quote Originally Posted by SiperTed View Post
    Once I put the MOA Light Spring in I had no problems either. Although, I haven't shot anything less than 1200 FPS so far which, previously, I had a problem with 1200 FPS.
    Weird. I got a notice about the quote and response you sent about the rounds youíll be testing, but it doesnít show up when I view the thread.

    Anyway, Iíll be interested to see your results. I ordered some LE12700. Iíll report back when I get it and shoot some.

    Not really surprised by the issues w light loads. Had the same issues w an M1S90 back in my early 3 gun days. Had to send it off to have the bolt lightened to get it to run w light loads reliably.
    Formerly known as xpd54.
    The opinions expressed in this post are my own and do not reflect the opinions or policies of my employer.
    www.gunsnobbery.wordpress.com

  9. #119
    Quote Originally Posted by Lon View Post
    Weird. I got a notice about the quote and response you sent about the rounds youíll be testing, but it doesnít show up when I view the thread.

    Anyway, Iíll be interested to see your results. I ordered some LE12700. Iíll report back when I get it and shoot some.

    Not really surprised by the issues w light loads. Had the same issues w an M1S90 back in my early 3 gun days. Had to send it off to have the bolt lightened to get it to run w light loads reliably.
    Yeah, this is really weird. I'm not sure why my post did not show up. When I posted it it said it had to be approved by a forum moderator first and it's still not there. Not sure what is going on.
    Last edited by SiperTed; 07-01-2022 at 07:59 AM.

  10. #120
    Quote Originally Posted by Lon View Post
    Weird. I got a notice about the quote and response you sent about the rounds youíll be testing, but it doesnít show up when I view the thread.

    Anyway, Iíll be interested to see your results. I ordered some LE12700. Iíll report back when I get it and shoot some.

    Not really surprised by the issues w light loads. Had the same issues w an M1S90 back in my early 3 gun days. Had to send it off to have the bolt lightened to get it to run w light loads reliably.
    Hey Lon!

    Sorry for the delay. I got sidetracked last week and didn't get to the range until today.

    Okay, here are my results:

    Shell UPC Size Shot FPS Good Bad Notes
    Winchester Game & Target 020892020122 2.75" 8 1200 X Lots of Stovepipes and Failure to feed next round.
    Noble 9 Pellet 837913000861 2.75" 00 1200 X
    Rio 9 Pellet 8435101618700 2.75" 00 1345 X
    Hornady Critical Defense 8 Pellet 090255862409 2.75" 00 1600 X
    Mili 9 Pellet 860005040001 2.75" 00 1350 X
    Federal 8 Pellet (LE133 00) 029465023157 2.75" 00 1145 X Lots of Stovepipes and Failure to feed next round.
    Federal 9 Pellet (LE127 00) 029465025076 2.75" 00 1325 X
    Federal Top Gun 029465025922 2.75" 8 1180 X Lots of Stovepipes and Failure to feed next round.
    Federal Slug 029465009946 2.75" Slug 1520 X

    Keep in mind that I have the MOA Reduced Rate Recoil Spring installed which is supposed to make the Stoeger operate light loads (1145 FPS or greater) and as you can see above I couldn't fire ANY of the 1145 or 1180 FPS loads reliably and the 1200 FPS were a mixed bag. I'm not sure why the Noble 1200 FPS worked but the other 1200 FPS #8 shot didn't. I do know that with the stock spring that I couldn't even fire ANY 1200 FPS reliably so the fact that the Noble 00 Buck worked like a champ is a plus but I guess I'm a bit disappointed since that is what I bought the light spring for - to operate these even lower than 1200 FPS low recoil loads.

    Anyone else having issues firing 1200 FPS or lighter loads WITH the MOA light spring?

    For a comparison, I also brought my RIA VR80 to the range and that is gas operated, not inertia driven like my Stoeger, and I had ZERO issues with any of the above rounds. They all fired smooth like butter in the VR80.
    Last edited by SiperTed; 07-09-2022 at 04:06 PM.

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •