Results 1 to 7 of 7

Thread: Poly 80 Glock 17 problem

  1. #1
    Member
    Join Date
    Jan 2019
    Location
    Pennsylvania

    Poly 80 Glock 17 problem

    I came across a poly 80 model 17 lower. It came with the jig, drilled the pin holes, removed the plastic where required. This particular 80 does not have the medal rear rails, instead the plastic gets channeled to crest the rear rail.

    Bought all Glock factory 17 parts to complete the lower. No problems. Took the factory complete slide off another gun put it on this poly 80 to check figment, trigger break and trigger reset all good.

    Range day insert mag, factory Glock mag and magpul mag, racked it and it felt stiff and didnít want to let the slide go freely forward. Trigger would not pull. Racked the slide and the round ejected like it should.

    Got home and started comparing the poly 80 to the factory gen 3 17. Note the poly 80 is gen 3 also with all gen 3 internals. The front block rails on this 80 do not pin in, there are two very small screws. I took the recoil spring out set it down in there and felt it might have been to tight compared to the factory 17. I filed some material away including the two screws that were resting against the recoil spring. Also put one round in a magazine and put it in the factory 17, outlined the trigger housing ejector with a sharpie on the shell casing. Put it in the 80, ejector was more left. Gave it a gentle tweak. Reassemble. Slide on. Feels better. I go outside. Safe backstop etc. this time she fired. One shot, ejected the spent shell, but the slide is still not freely going the full motion forward.

    Iím heading in the right direction but this thing sure is a pain in the ass. One thing I did notice that I havenít addressed or measured, the ejector in the poly seems ever so slightly longer. I will measure and take some material off if it actually is. There also feels like a slight rough spot when sliding the slide onto the poly 80 near the trigger bar. Going to look at this.

    Has anybody had the poly 80 with the front block that screws in not pinned. Any tricks. Any help.
    Attached Images Attached Images   

  2. #2
    TOLERATED BY STEPHANIE LittleLebowski's Avatar
    Join Date
    Feb 2011
    Location
    VA
    Mark every metal part you can with a Sharpie to show rubbing, but I bet you didnít hog out the RSA channel enough.

  3. #3
    Member
    Join Date
    Jan 2019
    Location
    Pennsylvania
    Iím going to hog it some more. Hogged it to the point at least it fired. I will get back in there take some more out

  4. #4
    Site Supporter
    Join Date
    Aug 2014
    Location
    Northern Virginia
    How does the slide without RSA+Barrel move on the frame?

    Chris

  5. #5
    Site Supporter hufnagel's Avatar
    Join Date
    Feb 2011
    Location
    NJ 07922
    RSA channel is definitely not clearanced enough.
    that screw sticking into the channel is bizarre, as I've never seen that, and is going to cause problems.
    Rules to live by: 1. Eat meat, 2. Shoot guns, 3. Fire, 4. Gasoline, 5. Make juniors
    TDA: Learn it. Live it. Love it.... Read these: People Management Triggers 1, 2, 3
    If anyone sees a broken image of mine, please PM me.

  6. #6
    Member
    Join Date
    Jan 2019
    Location
    Pennsylvania
    I hogged those screws flat. Hogged out the channel some more tonight. There was a slight rough spot at the back of the channel for the rsa I think I got it smoothed out. Shouldnít even admit this but the slide felt like it had a rough spot where the top of the trigger bar was touching the firing pin safety plunger. Took the file a couple strokes on it and it felt better. Trigger was resetting fine. Well couldnít leave well enough alone went a little to far now sometimes on the reset the trigger breaks again. Going to have to order another. Itís getting there. Really wish this poly 80 was a little more normal as far as the front block etc as some others I have seen. Pita.

  7. #7
    Member Gary1911A1's Avatar
    Join Date
    Jan 2012
    Location
    Portsmouth, OH
    I have found this guy's videos to be very helpful.
    https://www.youtube.com/channel/UCcj...D89PTNYkMNzKww

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •