Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: trouble installing the E2 grip module on a P226

  1. #11
    I apologize for taking so long to update. I tried all the suggestions in the thread and nothing worked. Eventually, I broke down and took the pistol to the gunsmith. This gunsmith has a store front, and the first time I went there for anything was in 2005. I've never needed to have much done, but he's usually pretty quick and prices are very reasonable. Anyway, he stopped what he was doing and spent about 15 minutes trying to get the grips on. Every time they ended up the same way as when I put them on. He said that it was not a problem he'd run into before and suggested I contact Sig and raise the possibility that the the grip module is defective. He didn't charge me, so I bought a box of 9mm ammo and left. That's where I am now. I haven't contacted Sig yet, but maybe I'll get around to that this weekend.

  2. #12
    Site Supporter MGW's Avatar
    Join Date
    May 2012
    Location
    Kansas
    I would be interested in hearing what you find out.
    If you know the way broadly you will see it in everything." - Miyamoto Musashi

  3. #13
    Site Supporter taadski's Avatar
    Join Date
    Mar 2012
    Location
    Colorado
    If you drop me a pm with your address, Ill bump you an extra E2 grip that is definitely functional.

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •